% meteor run android
                                              
Your system does not yet seem to fulfill all requirements to build apps for Android.
                                              
Please follow the installation instructions in the mobile guide:
http://guide.meteor.com/cordova.html#installing-prerequisites
                                              
Status of the individual requirements:        
✓ Java JDK                                    
✓ Android SDK                                 
✗ Android target: Please install Android target / API level: "android-29".
            Hint: Open the SDK manager by running: /Users/breadfit/Library/Android/sdk/tools/android
            You will require:
            1. "SDK Platform" for API level android-29
            2. "Android SDK Platform-tools (latest)
            3. "Android SDK Build-tools" (latest)
            
✓ Gradle    


% cd ~/Library/Android/sdk/cmdline-tools/latest/bin
% ./sdkmanager "platforms;android-29"
[=======================================] 100% Unzipping... android-10/framework
% meteor run android

...

Build-tool 31.0.0 is missing DX at /Users/breadfit/Library/Android/sdk/build-tools/31.0.0/dx

FAILURE: Build failed with an exception.

* What went wrong:
Could not determine the dependencies of task ':app:compileDebugJavaWithJavac'.
> Installed Build Tools revision 31.0.0 is corrupted. Remove and install again using the SDK Manager.

...


% cd ~/Library/Android/sdk/build-tools/31.0.0
% mv d8 dx \
% cd lib  \
% mv d8.jar dx.jar